summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-26 12:49:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-26 13:39:18 +0100
commit28ba01aec6d998ffffc819458db308d691948246 (patch)
treed46f148cb19f05598e3ea8e12ba2dae40cf9519f /gnu/packages/cmake.scm
parent11f4d87756dfc83656021c5aae00850724997ee0 (diff)
downloadguix-28ba01aec6d998ffffc819458db308d691948246.tar.gz
guix-28ba01aec6d998ffffc819458db308d691948246.tar.xz
gnu: cmake: Enable debugging information.
* gnu/packages/cmake.scm (cmake)[arguments]: Set #:build-type.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index ecabc8a763..93a71e1d92 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -300,6 +300,10 @@ and workspaces that can be used in the compiler environment of your choice.")
(if (%current-target-system)
cmake-minimal-cross
cmake-minimal))
+
+ ;; Enable debugging information for convenience.
+ ((#:build-type _ #f) "RelWithDebInfo")
+
((#:configure-flags flags ''())
`(append (list "-DSPHINX_INFO=ON" "-DSPHINX_MAN=ON" "-DSPHINX_HTML=ON"
(string-append "-DCMAKE_DOC_DIR=share/doc/cmake-"