summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-17 16:17:20 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-17 16:27:15 +0200
commit9ff87bb99614923fa3336ab4bbf22e3444709b48 (patch)
treefa169a6cc0fdc8d92bb4c4a4f265afc2ba29a890 /gnu/packages/cmake.scm
parentae71bef532d6b1c9d1481a3ac65827f148b1e45b (diff)
parent9e8e252026f558933bdd9cfc26a75d13954b3e8e (diff)
downloadguix-9ff87bb99614923fa3336ab4bbf22e3444709b48.tar.gz
guix-9ff87bb99614923fa3336ab4bbf22e3444709b48.tar.xz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 1d8d829ec5..64349be444 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -207,6 +207,18 @@ and workspaces that can be used in the compiler environment of your choice.")
(outputs '("out" "doc"))
(properties (alist-delete 'hidden? (package-properties cmake-minimal)))))
+(define-public cmake/fixed
+ ;; This is a variant of CMake that fixes X.509 certificate lookup:
+ ;; <https://issues.guix.gnu.org/issue/37371>.
+ (package
+ (inherit cmake)
+ (version (string-append (package-version cmake) "-1"))
+ (source (origin
+ (inherit (package-source cmake))
+ (patches
+ (append (search-patches "cmake-curl-certificates.patch")
+ (origin-patches (package-source cmake))))))))
+
(define-public emacs-cmake-mode
(package
(inherit cmake)