summaryrefslogtreecommitdiff
path: root/gnu/packages/debian.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-23 15:10:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-23 21:59:48 +0300
commit658525f6ecdfdf4929910a5a45d33150d0e43f6e (patch)
treeb5fbd329f05febec64c5a4dafa4a7d13cdba3423 /gnu/packages/debian.scm
parent2bd17f8a15f414471b63412d0a2d4c2253e760c0 (diff)
downloadguix-658525f6ecdfdf4929910a5a45d33150d0e43f6e.tar.gz
guix-658525f6ecdfdf4929910a5a45d33150d0e43f6e.tar.xz
gnu: debootstrap: Patch reference to dpkg.
* gnu/packages/debian.scm (debootstrap)[arguments]: Adjust 'patch-source phase to also patch a reference to dpkg. [inputs]: Add dpkg.
Diffstat (limited to 'gnu/packages/debian.scm')
-rw-r--r--gnu/packages/debian.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 65132d9259..6b471d6cc5 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -208,6 +208,7 @@ contains the archive keys used for that.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(tzdata (assoc-ref inputs "tzdata"))
+ (dpkg (assoc-ref inputs "dpkg"))
(debian (assoc-ref inputs "debian-keyring"))
(ubuntu (assoc-ref inputs "ubuntu-keyring")))
(substitute* "Makefile"
@@ -224,7 +225,8 @@ contains the archive keys used for that.")
(substitute* "scripts/gutsy"
(("/usr") ubuntu))
(substitute* "debootstrap"
- (("=/usr") (string-append "=" out)))
+ (("=/usr") (string-append "=" out))
+ (("/usr/bin/dpkg") (string-append dpkg "/bin/dpkg")))
;; Ensure PATH works both in guix and within the debian chroot
;; workaround for: https://bugs.debian.org/929889
(substitute* "functions"
@@ -252,6 +254,7 @@ contains the archive keys used for that.")
(inputs
`(("debian-keyring" ,debian-archive-keyring)
("ubuntu-keyring" ,ubuntu-keyring)
+ ("dpkg" ,dpkg)
("tzdata" ,tzdata)
;; Called at run-time from various places, needs to be in PATH.