summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-04-07 22:01:22 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-07 22:32:01 +0200
commitace3a7ad89b1cc5c16cf2455248014b222b0f945 (patch)
treedfc77d38a198f623b6aa8e8314bf0057c61635cb /gnu/packages/engineering.scm
parent21594c06b1b63b9e7b9a5c95ea5f063c34233eed (diff)
downloadguix-ace3a7ad89b1cc5c16cf2455248014b222b0f945.tar.gz
guix-ace3a7ad89b1cc5c16cf2455248014b222b0f945.tar.xz
gnu: Add libnest2d-for-cura.
* gnu/packages/engineering.scm (libnest2d-for-cura): New variable.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 0bf4681ea1..a1f96771a1 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages cmake)
#:use-module (gnu packages commencement)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages curl)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages digest)
@@ -3431,6 +3432,37 @@ related desktop applications using PyQt5. It belongs to the Cura project
from Ultimaker.")
(license license:lgpl3+)))
+(define-public libnest2d-for-cura
+ ;; Cura uses a custom fork of the libnest2d library.
+ (package
+ (name "libnest2d-for-cura")
+ (version "4.12.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ultimaker/libnest2d")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wk7cv8sqnxy7srq61scrr18dz2i0l4s4slmjfh4890iy0wf9i7n"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list boost clipper nlopt))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-clipper-detection
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CLIPPER_PATH" (assoc-ref inputs "clipper")))))))
+ (home-page "https://github.com/Ultimaker/libnest2d")
+ (synopsis "2D irregular bin packaging and nesting library")
+ (description
+ "Libnest2D is a library and framework for the 2D bin packaging
+problem. It was inspired from the SVGNest Javascript library.")
+ (license license:lgpl3)))
+
(define-public libcharon
(package
(name "libcharon")