summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2021-09-22 21:25:22 +0000
committerArun Isaac <arunisaac@systemreboot.net>2021-10-02 16:28:59 +0530
commit017bf198f45327dd5d404be0cd43dc24b88a6ef6 (patch)
tree3b24e4f66a72d69a1f12737ebb505b2beaafac9f /gnu/packages/file-systems.scm
parentfed255a3d923993fb7b39dd49e39fe153d682d8f (diff)
downloadguix-017bf198f45327dd5d404be0cd43dc24b88a6ef6.tar.gz
guix-017bf198f45327dd5d404be0cd43dc24b88a6ef6.tar.xz
gnu: zfs: Update to 2.1.1.
* gnu/packages/file-systems.scm (zfs): Update to 2.1.1. [arguments]: Do not return #t from custom phases. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 82b5444d02..be1e987223 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1175,7 +1176,7 @@ with the included @command{xfstests-check} helper.")
(define-public zfs
(package
(name "zfs")
- (version "2.1.0")
+ (version "2.1.1")
(outputs '("out" "module" "src"))
(source
(origin
@@ -1184,7 +1185,7 @@ with the included @command{xfstests-check} helper.")
"/download/zfs-" version
"/zfs-" version ".tar.gz"))
(sha256
- (base32 "0kzkggwznp4m3503f2m4lcinbl99jg50j4asrwfpfk1862vdrgb0"))))
+ (base32 "1zsc0zkz5cci6pxc0kwzn3xg72qv2fq65phb768y5dgk1784hkxx"))))
(build-system linux-module-build-system)
(arguments
`(;; The ZFS kernel module should not be downloaded since the license
@@ -1278,8 +1279,7 @@ with the included @command{xfstests-check} helper.")
(substitute* '("Makefile.am" "Makefile.in")
(("\\$\\(prefix)/src") (string-append src "/src")))
(substitute* (find-files "udev/rules.d/" ".rules.in$")
- (("/sbin/modprobe") (string-append kmod "/bin/modprobe"))))
- #t))
+ (("/sbin/modprobe") (string-append kmod "/bin/modprobe"))))))
(replace 'build
(lambda _ (invoke "make")))
(replace 'install
@@ -1294,8 +1294,8 @@ with the included @command{xfstests-check} helper.")
(string-append "INSTALL_MOD_PATH=" moddir)
"INSTALL_MOD_STRIP=1")
(install-file "contrib/bash_completion.d/zfs"
- (string-append out "/share/bash-completion/completions"))
- #t))))))
+ (string-append out
+ "/share/bash-completion/completions"))))))))
(native-inputs
`(("attr" ,attr)
("kmod" ,kmod)