summaryrefslogtreecommitdiff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-07 21:28:38 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-07 22:10:16 +0100
commitcc43d807c08af02d31770a011881990d46428737 (patch)
treed8291f725cf0483db2394001330538a3cba70000 /gnu/packages/file.scm
parent8ad8568bb5974a42a479a0c2158e105b209aa253 (diff)
downloadguix-cc43d807c08af02d31770a011881990d46428737.tar.gz
guix-cc43d807c08af02d31770a011881990d46428737.tar.xz
gnu: file: Incorporate grafted changes.
* gnu/packages/file.scm (file)[replacement]: Remove. [source](patches): New field. (file/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 4518c8d3dc..24ed37a9d2 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -31,11 +31,11 @@
(package
(name "file")
(version "5.33")
- (replacement file/fixed)
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.astron.com/pub/file/file-"
version ".tar.gz"))
+ (patches (search-patches "file-CVE-2018-10360.patch"))
(sha256
(base32
"1iipnwjkag7q04zjkaqic41r9nlw0ml6mhqian6qkkbisb1whlhw"))))
@@ -53,10 +53,3 @@ extensions to tell you the type of a file, but looks at the actual contents
of the file. This package provides the libmagic library.")
(license bsd-2)
(home-page "https://www.darwinsys.com/file/")))
-
-(define file/fixed
- (package
- (inherit file)
- (source
- (origin (inherit (package-source file))
- (patches (search-patches "file-CVE-2018-10360.patch"))))))