summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-05-24 10:46:45 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-22 00:11:15 -0400
commit6e0b2adf5f80d42f3a0e09e7de2bcfe188678997 (patch)
tree6093d7fdaab018d8bf92e98ea28ea821bd492e80 /gnu/packages/fonts.scm
parentad07af353877f8f438d92b04eeb4955f077ca499 (diff)
downloadguix-6e0b2adf5f80d42f3a0e09e7de2bcfe188678997.tar.gz
guix-6e0b2adf5f80d42f3a0e09e7de2bcfe188678997.tar.xz
gnu: Add font-ipa-ex.
* gnu/packages/fonts.scm (font-ipa-ex): New variable. Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 89c9afedeb..eaa11b1c81 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,53 @@ orthography of Roman glyphs of Meera Inimai are also based on this
characteristic so that they sit smoothly with the Tamil glyphs.")
(license license:silofl1.1)))
+(define-public font-ipa-ex
+ (package
+ (name "font-ipa-ex")
+ (version "004.01")
+ (source (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append
+ "https://moji.or.jp/wp-content/ipafont/IPAexfont/"
+ "IPAexfont" (string-join (string-split version #\.) "")
+ ".zip"))
+ (sha256
+ (base32
+ "0jwpszgisrls1lsgq1ngcm99zjaikb8hshr02512qrzrnd53gy5w"))))
+ (build-system font-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'make-read-only
+ (lambda _
+ ;; Otherwise the files have the executable bit set.
+ (for-each (lambda (file)
+ (chmod file #o444))
+ (find-files "." #:directories? #f))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((font+version
+ #$(string-append
+ "IPAexfont"
+ (string-join (string-split version #\.) "")))
+ (doc-dir (string-append #$output "/share/doc/" #$name)))
+ (with-directory-excursion font+version
+ (mkdir-p doc-dir)
+ (copy-file (string-append "Readme_" font+version ".txt")
+ (string-append doc-dir "/README"))
+ (copy-file "IPA_Font_License_Agreement_v1.0.txt"
+ (string-append doc-dir "/LICENSE")))))))))
+ (home-page "https://moji.or.jp/ipafont/")
+ (synopsis "Japanese font from the Information-technology Promotion Agency")
+ (description "IPAex Fonts are suitable for both display and printing.
+This is a modernized version of IPA Fonts that aims to provide a good balance
+for authoring Japanese documents mixed with Western characters, while
+following Japanese printing tradition. Japanese characters (Kanji, Kana and
+punctuation marks) are full width mono-space pitch, and Western characters are
+proportional pitch.")
+ (license license:ipa)))
+
(define-public font-ipa-mj-mincho
(package
(name "font-ipa-mj-mincho")