summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-20 12:13:44 -0400
committerMark H Weaver <mhw@netris.org>2014-08-20 12:16:13 -0400
commitc3114b756760ddb73054a4bc3d5eff0bfe47c4de (patch)
treec0d849ae59187a2c4ff9daf0e8f515ffa4161ce4 /gnu/packages/gawk.scm
parent06a70dbec116efaf70ee29341921197496b06139 (diff)
downloadguix-c3114b756760ddb73054a4bc3d5eff0bfe47c4de.tar.gz
guix-c3114b756760ddb73054a4bc3d5eff0bfe47c4de.tar.xz
gnu: Add 'file' as a native-input on MIPS for some packages.
* gnu/packages/admin.scm (sudo): gnu/packages/gawk.scm (gawk): Add 'file' as a native input on MIPS. Remove earlier workaround on MIPS. * gnu/packages/libffi.scm (libffi): gnu/packages/bdw-gc.scm (libatomic-ops, libgc): Add 'file' as a native input on MIPS.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 6185409fb7..737e610ae5 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -20,6 +20,7 @@
(define-module (gnu packages gawk)
#:use-module (guix licenses)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages file)
#:use-module (gnu packages libsigsegv)
#:use-module (guix packages)
#:use-module (guix download)
@@ -55,17 +56,6 @@
'((substitute* "extension/Makefile.in"
(("^.*: check-for-shared-lib-support" match)
(string-append "### " match))))
- '())
-
- ;; XXX FIXME gawk 4.1.1 was bootstrapped with a prerelease
- ;; libtool, which fails on MIPS in the absence of
- ;; /usr/bin/file. As a temporary workaround, we patch
- ;; the configure script to hardcode use of the little
- ;; endian N32 ABI on MIPS.
- ,@(if (equal? "mips64el-linux" (or (%current-target-system)
- (%current-system)))
- '((substitute* "extension/configure"
- (("\\$emul") "elf32ltsmipn32")))
'())))
%standard-phases)))
(inputs `(("libsigsegv" ,libsigsegv)
@@ -73,7 +63,12 @@
,@(if (%current-target-system)
`(("bash" ,bash))
'())))
-
+ (native-inputs
+ `(;; 'file' is needed by the pre-release libtool on MIPS.
+ ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+ (%current-system)))
+ `(("file" ,file))
+ '())))
(home-page "http://www.gnu.org/software/gawk/")
(synopsis "A text scanning and processing language")
(description