summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorNikolay Korotkiy <sikmir@gmail.com>2021-12-27 18:02:04 +0300
committerLeo Famulari <leo@famulari.name>2021-12-27 19:16:46 -0500
commitd42718f8eafabbfa8e0e8415bc5aa7919d9326be (patch)
tree9656690a9fb279f06b8cbeafe8cafa5f1efa5e02 /gnu/packages/geo.scm
parent4db16b9cbca1d14d83c06d54cfce4772390f6176 (diff)
downloadguix-d42718f8eafabbfa8e0e8415bc5aa7919d9326be.tar.gz
guix-d42718f8eafabbfa8e0e8415bc5aa7919d9326be.tar.xz
gnu: proj: Fix version number in CMake build scripts.
* gnu/packages/geo.scm (proj)[arguments]: Add a 'fix-version' build phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index f7866d4b4b..8e5965c97c 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -517,7 +517,13 @@ fully fledged Spatial SQL capabilities.")
"050apzdn0isxpsblys1shrl9ccli5vd32kgswlgx1imrbwpg915k"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")))
+ `(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-version
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("MAJOR 7 MINOR 2 PATCH 0") "MAJOR 7 MINOR 2 PATCH 1")))))))
(inputs
(list curl libjpeg-turbo libtiff sqlite))
(native-inputs