summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-13 21:54:43 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-18 11:40:09 -0500
commit67f01c8d293862e70f84569595f84f822b6f2af5 (patch)
tree8ad6717a2041a936f1f718a684f7e33ff3f23050 /gnu/packages/gl.scm
parentb3e1f58f2e4b984d5d221ad46262844348660e27 (diff)
downloadguix-67f01c8d293862e70f84569595f84f822b6f2af5.tar.gz
guix-67f01c8d293862e70f84569595f84f822b6f2af5.tar.xz
gnu: mesa: Update to 21.2.5.
* gnu/packages/gl.scm (mesa): Update to 21.2.5. [phases]{fix-tests}: Remove phase.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 19b53acd41..f5a72d9048 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -238,7 +238,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "21.2.4")
+ (version "21.2.5")
(source
(origin
(method url-fetch)
@@ -250,7 +250,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0i2vz3ppcgqm076546imzl11jr3rlch1iv62lffk60mcs61dwvpy"))
+ "1fxcdf4qs4vmyjcns7jv62w4jy3gr383ar5b7mr77nb0nxgmhjcf"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
@@ -396,11 +396,6 @@ also known as DXTn or DXTC) for Mesa.")
(("disasm\\.c'") "delay.c',\n link_args: ld_args_build_id"))))
(_
'((display "No tests to disable on this architecture.\n"))))))
- (add-after 'unpack 'fix-tests
- (lambda _
- ;; See <https://gitlab.freedesktop.org/mesa/mesa/-/issues/3181>.
- (substitute* "src/compiler/glsl/glcpp/tests/084-unbalanced-parentheses.c.expected"
- (("unexpected \\$end") "unexpected end of file"))))
(add-before 'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))