summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2022-04-02 21:34:18 +0300
committerLudovic Courtès <ludo@gnu.org>2022-04-05 20:41:40 +0200
commitd15a601a85c85431a691c2a3f85b9e6e0948a540 (patch)
treece34cc7575d07b3959635167cca1f6f862665a2f /gnu/packages/gnome.scm
parent86ee397e2658de915d79fd4ad6d2217b941b4682 (diff)
downloadguix-d15a601a85c85431a691c2a3f85b9e6e0948a540.tar.gz
guix-d15a601a85c85431a691c2a3f85b9e6e0948a540.tar.xz
gnu: phodav: Use libsoup 2 instead of libsoup 3.
Looks like phodav requires libsoup 2. Example of failing build logs, wanting libsoup 2.4: <https://ci.guix.gnu.org/build/584454/log/raw> After swapping the dependency, tests were failing due to HOME not being writable. I added a new build phase to account for this. I also removed the start-virtual-dir-server phase which no longer seems required, the tests pass without it. * gnu/packages/gnome.scm (phodav): Fix build, tests. [inputs]: Replace libsoup 3 with libsoup 2. [arguments]<#:phases>[set-temporary-home]: New phase. [arguments]<#:phases>[start-virtual-dir-server]: Remove phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8ff59f084b..19adb67423 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2022 Leo Nikkilä <hello@lnikki.la>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1191,12 +1192,10 @@ Library reference documentation.")
(substitute* "data/meson.build"
(("udev\\.get_pkgconfig_variable\\('udevdir'\\)")
(format #f "'~a'" rules))))))
- (add-before 'check 'start-virtual-dir-server
- ;; The same server when started by tests/virtual-dir returns an
- ;; unexpected status (4 instead of 200) and fails a test. It is
- ;; unclear why starting it manually here makes it pass.
+ (add-before 'check 'set-temporary-home
+ ;; Tests want to write into HOME.
(lambda _
- (system "tests/virtual-dir-server &"))))))
+ (setenv "HOME" "/tmp"))))))
(native-inputs
`(("docbook-xml" ,docbook-xml-4.3)
("gettext" ,gettext-minimal)
@@ -1205,7 +1204,7 @@ Library reference documentation.")
("gtk-doc" ,gtk-doc/stable)
("pkg-config" ,pkg-config)))
(inputs
- (list avahi libgudev libsoup))
+ (list avahi libgudev libsoup-minimal-2))
(synopsis "WebDav server implementation using libsoup")
(description "PhoDav was initially developed as a file-sharing mechanism for Spice,
but it is generic enough to be reused in other projects,