summaryrefslogtreecommitdiff
path: root/gnu/packages/jami.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-30 16:57:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-02 07:41:16 -0400
commit3f742c77ef26d38bce0ce99619491ade8686a77f (patch)
tree8d6a483636e96d7d84f4e0c5f7de3b2bb72b4e27 /gnu/packages/jami.scm
parent3d913c1ed80470fde408a6f4509e8ae1277f40fb (diff)
downloadguix-3f742c77ef26d38bce0ce99619491ade8686a77f.tar.gz
guix-3f742c77ef26d38bce0ce99619491ade8686a77f.tar.xz
ffmpeg-jami: Apply patches from Jami 20210326.1.cfba013.
* gnu/packages/jami.scm (ffmpeg-jami): Remove trailing #t. [phases] <apply-patches>: Add libopusdec-enable-FEC and libopusenc-enable-FEC to the list of patches to apply.
Diffstat (limited to 'gnu/packages/jami.scm')
-rw-r--r--gnu/packages/jami.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 35d84bb37b..9d5d00c60c 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -403,21 +403,22 @@ of Jami."
`(modify-phases ,phases
(add-after 'unpack 'make-git-checkout-writable
(lambda _
- (for-each make-file-writable (find-files "."))
- #t))
+ (for-each make-file-writable (find-files "."))))
(add-after 'unpack 'apply-patches
(lambda* (#:key inputs #:allow-other-keys)
(let ((jami-apply-dependency-patches
,jami-apply-dependency-patches))
;; These patches come from:
;; "ring-project/daemon/contrib/src/ffmpeg/rules.mak".
- (jami-apply-dependency-patches #:inputs inputs
- #:dep-name "ffmpeg"
- #:patches
- '("remove-mjpeg-log"
- "change-RTCP-ratio"
- "rtp_ext_abs_send_time"))
- #t))))))))))
+ (jami-apply-dependency-patches
+ #:inputs inputs
+ #:dep-name "ffmpeg"
+ #:patches
+ '("remove-mjpeg-log"
+ "change-RTCP-ratio"
+ "rtp_ext_abs_send_time"
+ "libopusdec-enable-FEC"
+ "libopusenc-enable-FEC"))))))))))))
(define-public libring
(package