summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-18 12:07:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-18 12:07:33 +0300
commitc9484c9c9944f65a69cf6182caf442d9285f3a65 (patch)
treef1e5a29619491e433dd47595a5373fa675b46bb2 /gnu/packages/julia.scm
parentd6f4dc1db488b5fbfdbdfe056308d881f30b27f2 (diff)
downloadguix-c9484c9c9944f65a69cf6182caf442d9285f3a65.tar.gz
guix-c9484c9c9944f65a69cf6182caf442d9285f3a65.tar.xz
gnu: julia: Fix building.
* gnu/packages/julia.scm (julia)[arguments]: Adjust 'adjust-test-suite phase to account for newer package versions.
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 1ede2b0d57..636bdc57c1 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -460,6 +460,8 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(let ((pcre2 (assoc-ref inputs "pcre2"))
(mbedtls-apache (assoc-ref inputs "mbedtls"))
(mpfr (assoc-ref inputs "mpfr"))
+ (gmp (assoc-ref inputs "gmp"))
+ (nghttp2 (assoc-ref inputs "libnghttp2"))
(suitesparse (assoc-ref inputs "suitesparse")))
;; Some tests only check to see if the input is the correct version.
(substitute* "stdlib/PCRE2_jll/test/runtests.jl"
@@ -468,6 +470,10 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(("2.24.0") ,(package-version mbedtls-apache)))
(substitute* "stdlib/MPFR_jll/test/runtests.jl"
(("4.1.0") ,(package-version mpfr)))
+ (substitute* "stdlib/GMP_jll/test/runtests.jl"
+ (("6.2.0") ,(package-version gmp)))
+ (substitute* "stdlib/nghttp2_jll/test/runtests.jl"
+ (("1.41.0") ,(package-version nghttp2)))
(substitute* "stdlib/SuiteSparse_jll/test/runtests.jl"
(("5004") ,(string-replace-substring
(version-major+minor