summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-18 21:53:57 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-18 23:08:29 +0200
commit2835fb07bacd5e99e99120eb9f3b7004a872f574 (patch)
tree7b8787e70666f02522c7eeef77aba4b6b629ea21 /gnu/packages/jupyter.scm
parent2cde4a967d162dc46cc1f6967ed21b196c14c338 (diff)
downloadguix-2835fb07bacd5e99e99120eb9f3b7004a872f574.tar.gz
guix-2835fb07bacd5e99e99120eb9f3b7004a872f574.tar.xz
gnu: Add python-jupyter-kernel-mgmt.
* gnu/packages/jupyter.scm (python-jupyter-kernel-mgmt): New variable.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index c7c1318808..bcea43f11c 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -55,3 +55,34 @@
protocol} to be used by both clients and kernels.")
(license license:bsd-3)
(properties '((upstream-name . "jupyter_protocol")))))
+
+(define-public python-jupyter-kernel-mgmt
+ (package
+ (name "python-jupyter-kernel-mgmt")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_kernel_mgmt" version))
+ (sha256
+ (base32
+ "0i7a78dn89ca8h0a42giyxwcmk6y4wrdr7q8h2ax9vybb84c795q"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-entrypoints" ,python-entrypoints)
+ ("python-jupyter-core" ,python-jupyter-core)
+ ("python-jupyter-protocol" ,python-jupyter-protocol)
+ ("python-pyzmq" ,python-pyzmq)
+ ("python-traitlets" ,python-traitlets)))
+ (native-inputs
+ `(("python-ipykernel" ,python-ipykernel)
+ ("python-ipython" ,python-ipython)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://jupyter.org")
+ (synopsis "Discover, launch, and communicate with Jupyter kernels")
+ (description
+ "This package is an experimental refactoring of the machinery for
+launching and using Jupyter kernels.")
+ (license license:bsd-3)
+ (properties '((upstream-name . "jupyter_kernel_mgmt")))))