summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 22:12:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:57 -0400
commitbf17d082566f6c912bc0bd75e3e1791ad2cc7901 (patch)
tree9040d0f5c74c886b17092b0f6bc83e09c8030730 /gnu/packages/jupyter.scm
parent1178fdee3bdc6072c080fed37911f949e7fcbc14 (diff)
downloadguix-bf17d082566f6c912bc0bd75e3e1791ad2cc7901.tar.gz
guix-bf17d082566f6c912bc0bd75e3e1791ad2cc7901.tar.xz
gnu: python-jupyter-kernel-mgmt: Update to 0.5.1 and disable tests.
* gnu/packages/jupyter.scm (python-jupyter-kernel-mgmt): Update to 0.5.1. [arguments]: New field. [propagated-inputs]: Add python-tornado. [native-inputs]: Remove python-mock. Add python-async-generator and python-pytest-asyncio.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 9c5ae23f79..336af2e24a 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -82,23 +82,40 @@ protocol} to be used by both clients and kernels.")
(define-public python-jupyter-kernel-mgmt
(package
(name "python-jupyter-kernel-mgmt")
- (version "0.4.0")
+ (version "0.5.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "jupyter_kernel_mgmt" version))
(sha256
(base32
- "0i7a78dn89ca8h0a42giyxwcmk6y4wrdr7q8h2ax9vybb84c795q"))))
+ "0977ixfi1pzjgy84hl0zycg4wpllmid98fhzcpy0lxd322w4sl7x"))))
(build-system python-build-system)
+ (arguments
+ (list
+ ;; There are 8 test failures, most of them in 'test_client_loop.py'
+ ;; (see: https://github.com/takluyver/jupyter_kernel_mgmt/issues/48).
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (invoke "pytest" "-vv" "jupyter_kernel_mgmt")))))))
(propagated-inputs
(list python-dateutil
python-entrypoints
python-jupyter-core
python-jupyter-protocol
python-pyzmq
+ python-tornado
python-traitlets))
(native-inputs
- (list python-ipykernel python-ipython python-mock python-pytest))
+ (list python-async-generator
+ python-ipykernel
+ python-ipython
+ python-pytest
+ python-pytest-asyncio))
(home-page "https://jupyter.org")
(synopsis "Discover, launch, and communicate with Jupyter kernels")
(description