summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-06 10:48:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-06 13:02:58 +0200
commitea3cfeb665e4221ded31c896496f73c8aac01022 (patch)
treef766fd1da32b4f3998ff90cfb83cd3a0beaf2174 /gnu/packages/jupyter.scm
parente47b0804747c2efb2865a2cdfe813f0ae3733025 (diff)
downloadguix-ea3cfeb665e4221ded31c896496f73c8aac01022.tar.gz
guix-ea3cfeb665e4221ded31c896496f73c8aac01022.tar.xz
gnu: Add python-ipympl.
* gnu/packages/jupyter.scm (python-ipympl): New variable.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index dd5d2a5a55..97f7a5e73d 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -517,6 +517,34 @@ sending queries to an SPARQL endpoint and fetching & presenting the results in
a notebook.")
(license license:bsd-3)))
+(define-public python-ipympl
+ (package
+ (name "python-ipympl")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ipympl" version))
+ (sha256
+ (base32 "11rppjdqzgs4pfiq8gww5xkpbk21fp86vvv839v56b9rqq06j2b4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-ipython
+ python-ipython-genutils
+ python-ipywidgets
+ python-matplotlib
+ python-numpy
+ python-pillow
+ python-traitlets))
+ (native-inputs
+ (list python-jupyter-packaging))
+ (home-page "https://matplotlib.org/ipympl/")
+ (synopsis "Matplotlib Jupyter Extension")
+ (description "Leveraging the Jupyter interactive widgets framework, ipympl
+enables the interactive features of matplotlib in the Jupyter notebook and in
+JupyterLab.")
+ (license license:bsd-3)))
+
(define-public python-voila
(package
(name "python-voila")