summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-01-25 15:21:09 -0500
committerLeo Famulari <leo@famulari.name>2021-01-25 15:40:55 -0500
commit68dd78e2e47248b3e1e7ba1807a92a8374b39097 (patch)
treed38564293f285d688a55b23e8a6424c6b26213b1 /gnu/packages/kde.scm
parent8b55544212a90b0276df49596a3d373e5c2e8f5c (diff)
parent3f0af15131e524891df8c9f013f1be1597fe2d7e (diff)
downloadguix-68dd78e2e47248b3e1e7ba1807a92a8374b39097.tar.gz
guix-68dd78e2e47248b3e1e7ba1807a92a8374b39097.tar.xz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm64
1 files changed, 63 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 0cc47e6337..73a2289f04 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
@@ -714,6 +714,7 @@ different notification systems.")
("qtmultimedia" ,qtmultimedia)
("qtquickcontrols" ,qtquickcontrols)
("qtquickcontrols2" ,qtquickcontrols2)
+ ("qtwayland" ,qtwayland)
("qtx11extras" ,qtx11extras)))
(home-page "https://community.kde.org/KDEConnect")
(synopsis "Enable your devices to communicate with each other")
@@ -758,6 +759,40 @@ communicate with each other. Here's a few things KDE Connect can do:
charts.")
(license license:lgpl2.1+)))
+(define-public kdf
+ (package
+ (name "kdf")
+ (version "20.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/"
+ version "/src/kdf-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0ba67hs4vlb3qyvdzhnpmf8p62df12s8aqw4hzf9vnxff3qix5k1"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcmutils" ,kcmutils)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("knotifications" ,knotifications)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/system/kdk")
+ (synopsis "View Disk Usage")
+ (description "KDiskFree displays the available file devices (hard drive
+partitions, floppy and CD drives, etc.) along with information on their
+capacity, free space, type and mount point. It also allows you to mount and
+unmount drives and view them in a file manager.")
+ (license license:gpl2+)))
+
(define-public kcachegrind
(package
(name "kcachegrind")
@@ -913,6 +948,33 @@ Python, PHP, and Perl.")
a variety of formats, including PDF, PostScript, DejaVu, and EPub.")
(license license:gpl2+)))
+(define-public poxml
+ (package
+ (name "poxml")
+ (version "20.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://kde/stable/release-service/" version
+ "/src/poxml-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1smjvblx0jcv3afs2sr4qcmvhqd44iw24hvr9fppa3nxhrmjwmlk"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("gettext" ,gettext-minimal)
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/development")
+ (synopsis "Tools for translating DocBook XML files with Gettext")
+ (description "This is a collection of tools that facilitate translating
+DocBook XML files using Gettext message files (PO files). Also included are
+several command-line utilities for manipulating DocBook XML files, PO files and
+PO template files.")
+ (license license:gpl2+)))
+
(define-public kdegraphics-mobipocket
(package
(name "kdegraphics-mobipocket")