summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-16 23:48:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-17 09:50:44 -0400
commit7fcf4fa082d945963bc2bebdd61f364d537debc4 (patch)
tree7c29dc8b853f5e287bcf33e5fec116005152e0ed /gnu/packages/linphone.scm
parentcb4b60bceea1110f357af8e1f20cd32629774c84 (diff)
downloadguix-7fcf4fa082d945963bc2bebdd61f364d537debc4.tar.gz
guix-7fcf4fa082d945963bc2bebdd61f364d537debc4.tar.xz
gnu: linphoneqt: Remove obsolete phase.
Now that we have Qt 5.14, having SOURCE_DATE_EPOCH set prevents reproducibility problems with the Qt Resource Compiler (this was fixed upstream in Qt 5.13). * gnu/packages/linphone.scm (linphoneqt)[phases]: Remove obsolete 'set-qt-rcc-source-date-override phase.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm8
1 files changed, 0 insertions, 8 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index f96fff2fc4..14da150ced 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -512,14 +512,6 @@ and video calls or instant messaging capabilities to an application.")
`(#:tests? #f ; No test target
#:phases
(modify-phases %standard-phases
- (add-after 'set-paths 'set-qt-rcc-source-date-override
- (lambda _
- ;; This fixes a reproducibility problem where the Qt Resource
- ;; Compiler (RCC) includes timestamp of its source files
- ;; (see: https://reproducible-builds.org/docs/
- ;; deterministic-build-systems/#cmake-notes).
- (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
- #t))
(add-after 'unpack 'fix-cmake-error
(lambda _
;; This is fixed in commit efed2fd8 of the master branch.