summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-19 22:21:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-29 01:27:41 -0400
commitf7408b7d2983825e7afb6b4166088a8f6dda6f70 (patch)
tree7ff83ba5b530339bab38a56cdbc98f388e612686 /gnu/packages/linphone.scm
parent48b2202789c85b6ab2d10916e2b6b118efc18ea9 (diff)
downloadguix-f7408b7d2983825e7afb6b4166088a8f6dda6f70.tar.gz
guix-f7408b7d2983825e7afb6b4166088a8f6dda6f70.tar.xz
gnu: msopenh264: Update to 1.2.1-21.
* gnu/packages/linphone.scm (msopenh264) [source]: Switch to git repository. [version]: Update to 1.2.1. [patches]: Remove field. [inputs]: Add bctoolbox.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm67
1 files changed, 29 insertions, 38 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 7337e0ef1e..5b5c57b357 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -887,44 +887,35 @@ and video calls or instant messaging capabilities to an application.")
(deprecated-package "linphoneqt" linphone-desktop))
(define-public msopenh264
- (package
- (name "msopenh264")
- (version "1.2.1")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://www.linphone.org/releases/sources/plugins/"
- name "/" name "-" version ".tar.gz"))
- (sha256
- (base32 "0rdxgazm52560g52pp6mp3mwx6j1z3h2zyizzfycp8y8zi92fqm8"))
- (patches
- (list
- ;; For support for OpenH264 version >= 2.
- (origin
- (method url-fetch)
- (uri
- (string-append "https://gitlab.linphone.org/BC/public/msopenh264/"
- "commit/493d147d28c9a0f788ba4e50b47a1ce7b18bf326"
- ".diff"))
- (file-name "msopenh264-openh264.patch")
- (sha256
- (base32
- "0mmd7nz5n9ian4rcwn200nldmy5j0dpdrna7r32rqnaw82bx3kdb")))))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; No test target
- #:configure-flags
- (list "-DENABLE_STATIC=NO"))) ; Not required
- (inputs
- `(("mediastreamer2" ,mediastreamer2)
- ("openh264" ,openh264)
- ("ortp" ,ortp)))
- (synopsis "Media Streamer H.264 Codec")
- (description "MsOpenH264 is an H.264 encoder/decoder plugin for
-mediastreamer2 based on the openh264 library.")
- (home-page "https://gitlab.linphone.org/BC/public/msopenh264")
- (license license:gpl2+)))
+ (let ((commit "88697cc95140017760d6da408cb0efdc5e86e40a")
+ (revision "0"))
+ (package
+ (name "msopenh264")
+ (version (git-version "1.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.linphone.org/BC/public/msopenh264.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10y3b6s934f2wbsf60b3p0g6hffizjqrj5in8l4sida2fjdxlwwy"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list "-DENABLE_STATIC=NO"))) ; Not required
+ (inputs
+ `(("bctoolbox" ,bctoolbox)
+ ("mediastreamer2" ,mediastreamer2)
+ ("openh264" ,openh264)
+ ("ortp" ,ortp)))
+ (synopsis "Media Streamer H.264 Codec")
+ (description "MsOpenH264 is an H.264 encoder/decoder plugin for
+ mediastreamer2 based on the openh264 library.")
+ (home-page "https://gitlab.linphone.org/BC/public/msopenh264")
+ (license license:gpl2+))))
(define-public mssilk
(package