summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 15:28:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 15:40:45 +0100
commit2d6be35ea207c01193c5995b36523e8cd815cac9 (patch)
treefbbdc09f5e800df06e9a89514866c89fc848bb50 /gnu/packages/mpi.scm
parentdf4f960cb8ef43ba49345f26df266683beca2bbf (diff)
downloadguix-2d6be35ea207c01193c5995b36523e8cd815cac9.tar.gz
guix-2d6be35ea207c01193c5995b36523e8cd815cac9.tar.xz
gnu: Add openmpi-c++.
* gnu/packages/mpi.scm (openmpi-c++): New variable.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 2011cbcd29..77711c90ff 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Paul Garlick <pgarlick@tourbillion-technology.com>
-;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -310,6 +310,16 @@ software vendors, application developers and computer science researchers.")
;; See file://LICENSE
(license license:bsd-2)))
+(define-public openmpi-c++
+ (package/inherit openmpi
+ (name "openmpi-c++")
+ (outputs '("out"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments openmpi)
+ ((#:configure-flags flags)
+ `(cons "--enable-mpi-cxx" ,flags))))
+ (synopsis "C++ bindings for MPI")))
+
;; TODO: javadoc files contain timestamps.
(define-public java-openmpi
(package/inherit openmpi