summaryrefslogtreecommitdiff
path: root/gnu/packages/nettle.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-27 09:44:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-27 09:44:48 +0200
commit31bd09e5a8136405ef6456ec9de72718a5a0740a (patch)
tree023e5e063a1b018430e85c885082d98149706734 /gnu/packages/nettle.scm
parentfeefbb094632b40cb56ad9764ba6c88547ef13ff (diff)
downloadguix-31bd09e5a8136405ef6456ec9de72718a5a0740a.tar.gz
guix-31bd09e5a8136405ef6456ec9de72718a5a0740a.tar.xz
gnu: nettle: Update to 3.3.
* gnu/packages/nettle.scm (nettle): Update to 3.3. [home-page]: Use https.
Diffstat (limited to 'gnu/packages/nettle.scm')
-rw-r--r--gnu/packages/nettle.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index d1203dfe75..e4e0eedc05 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -47,7 +47,7 @@
(outputs '("out" "debug"))
(native-inputs `(("m4" ,m4)))
(propagated-inputs `(("gmp" ,gmp)))
- (home-page "http://www.lysator.liu.se/~nisse/nettle/")
+ (home-page "https://www.lysator.liu.se/~nisse/nettle/")
(synopsis "C library for low-level cryptographic functionality")
(description
"GNU Nettle is a low-level cryptographic library. It is designed to
@@ -60,14 +60,14 @@ themselves.")
;; This version is not API-compatible with version 2. In particular, lsh
;; cannot use it yet. So keep it separate.
(package (inherit nettle-2)
- (version "3.2")
+ (version "3.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/nettle/nettle-"
version ".tar.gz"))
(sha256
(base32
- "15wxhk52yc62rx0pddmry66hqm6z5brrrkx4npd3wh9nybg86hpa"))))
+ "07mif3af077763vc35s1x8vzhzlgqcgxh67c1xr13jnhslkjd526"))))
(arguments
(substitute-keyword-arguments (package-arguments nettle-2)
((#:configure-flags flags)