summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-01-14 15:34:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-01-20 22:34:04 +0100
commit41134f915f523601fa183f180b801a872b428fc3 (patch)
tree64a0f1672d4b9e7f0364eb1355f60bdbfeac7372 /gnu/packages/node.scm
parent683154166d51c26c8f7248d2a0f2b37cf84d343a (diff)
downloadguix-41134f915f523601fa183f180b801a872b428fc3.tar.gz
guix-41134f915f523601fa183f180b801a872b428fc3.tar.xz
gnu: libnode: Fix regression in unused phases.
Fixes regression introduced with commit 1d77141f6d5004cf10d1f9ead53855f25a973847. Reported by Pierre-Antoine Bouttier <pierre-antoine.bouttier@univ-grenoble-alpes.fr>. * gnu/packages/node.scm (libnode)[arguments]: Delete phase "patch-node-shebang". Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 9e07cd906e..a495f6d763 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -238,4 +239,5 @@ devices.")
`(cons* "--shared" "--without-npm" ,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
- (delete 'patch-npm-shebang)))))))
+ (delete 'patch-npm-shebang)
+ (delete 'patch-node-shebang)))))))