summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-22 03:47:40 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-04 21:07:06 -0400
commit158a64a7023301ecb4f7ef611ea037dd1b68e710 (patch)
tree804de268c2e062a144f3e96f26600ea9518d2abd /gnu/packages/perl.scm
parent8d27e6a7cf9238cae757c675c87e2bba2e2a16be (diff)
downloadguix-158a64a7023301ecb4f7ef611ea037dd1b68e710.tar.gz
guix-158a64a7023301ecb4f7ef611ea037dd1b68e710.tar.xz
gnu: Add perl-exporter.
* gnu/packages/perl.scm (perl-exporter): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d449abc78c..dac290a182 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4204,6 +4205,31 @@ command, which can be used as a minimal Perl read-eval-print loop (REPL).")
in your modules in a \"Java-esque\" manner.")
(license (package-license perl))))
+(define-public perl-exporter
+ (package
+ (name "perl-exporter")
+ (version "5.74")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TO/TODDR/"
+ "Exporter-" version ".tar.gz"))
+ (sha256
+ (base32 "1f25k5iaygiizlrkbbl6wxd647pwfmynykxalq6r9bbkysg8inza"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-pod" ,perl-test-pod)))
+ (propagated-inputs
+ `(("perl-carp" ,perl-carp)))
+ (home-page "https://metacpan.org/dist/Exporter")
+ (synopsis "Default import method for modules")
+ (description "Exporter implements an import method which allows a module to
+export functions and variables to its users' namespaces. Many modules use
+Exporter rather than implementing their own import method because Exporter
+provides a highly flexible interface, with an implementation optimised for the
+common case.")
+ (license (package-license perl))))
+
(define-public perl-exporter-lite
(package
(name "perl-exporter-lite")