summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-13 16:40:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:46 -0400
commitd72c53fa43a02cf7f9ddb975de01cb8514a6f806 (patch)
tree32b435fac9c40868fc0465556be6273ef286dfc8 /gnu/packages/python-check.scm
parent7d79d30e3a6911468a2eda0ba1e4d4494b411c01 (diff)
downloadguix-d72c53fa43a02cf7f9ddb975de01cb8514a6f806.tar.gz
guix-d72c53fa43a02cf7f9ddb975de01cb8514a6f806.tar.xz
gnu: python-nbval: Fix build.
* gnu/packages/python-check.scm (python-nbval) [phases]: Delete trailing #t. {check}: Skip newly failing 'test_conf_ignore_stderr' test. Remove INPUTS and OUTPUTS arguments. Add TESTS? and honor it.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 465c425a79..41b73172b0 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1342,17 +1342,21 @@ new fixtures, new methods and new comparison objects.")
(lambda _
;; This test fails because of a mismatch in the output of LaTeX
;; equation environments. Seems OK to skip.
- (delete-file "tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb")
- #t))
+ (delete-file
+ "tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb")))
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "-k"
- (string-append
- ;; This only works with Pytest < 5.
- "not nbdime_reporter"
- ;; https://github.com/computationalmodelling/nbval/pull/148.
- " and not test_timeouts")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; This only works with Pytest < 5.
+ "not nbdime_reporter"
+ ;; https://github.com/computationalmodelling/nbval/pull/148.
+ " and not test_timeouts"
+ ;; It seems the output format has changed; the following
+ ;; test fails with "Unexpected output fields from
+ ;; running code: {'text/plain'}".
+ " and not test_conf_ignore_stderr "))))))))
(native-inputs
(list python-pytest python-pytest-cov python-sympy))
(propagated-inputs