summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-18 00:43:16 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-01 23:41:42 +0200
commit150cf64b04dcb370124e02a5bb347e0617bae20c (patch)
tree209628d23039c5d3be1b2ce0b94d73b8e79e69bb /gnu/packages/python-crypto.scm
parent406f726cfb857e8b845a45d38d8f7d04867bd126 (diff)
downloadguix-150cf64b04dcb370124e02a5bb347e0617bae20c.tar.gz
guix-150cf64b04dcb370124e02a5bb347e0617bae20c.tar.xz
gnu: python-pycryptodome: Unbundle libtomcrypt.
* gnu/packages/python-crypto.scm (pycryptodome-unbundle-tomcrypt-snippet): New variable. (python-pycryptodome)[source]{snippet}: Unbundle libtomcrypt. (python-pycryptodome)[source]{modules}: Add (guix build utils). Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 6c25e0dd36..6d50ae682f 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,6 +45,7 @@
(define-module (gnu packages python-crypto)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module (gnu packages)
@@ -938,6 +940,22 @@ protocol (Javascript Object Signing and Encryption).")
(define-public python2-josepy
(package-with-python2 python-josepy))
+(define pycryptodome-unbundle-tomcrypt-snippet
+ #~(begin
+ ;; Unbundle libtomcrypt.
+ (delete-file-recursively "src/libtom")
+ (substitute* "src/DES.c"
+ (("#include \"libtom/tomcrypt_des.c\"")
+ "#include <tomcrypt.h>"))
+ (substitute* "setup.py"
+ (("include_dirs=\\['src/', 'src/libtom/'\\]")
+ ;; FIXME: why does '-ltomcrypt' need to be added
+ ;; manually, even when 'tomcrypt' is added to 'libraries'?
+ ;; This behaviour is not documented at
+ ;; <https://docs.python.org/3/extending/building.html>.
+ "include_dirs=['src/'], libraries=['tomcrypt', 'tommath'],
+ extra_link_args=['-ltomcrypt', '-ltommath']"))))
+
(define-public python-pycryptodome
(package
(name "python-pycryptodome")
@@ -948,8 +966,13 @@ protocol (Javascript Object Signing and Encryption).")
(uri (pypi-uri "pycryptodome" version))
(sha256
(base32
- "1i4m74f88qj9ci8rpyzrbk2slmsdj5ipmwdkq6qk24byalm203li"))))
+ "1i4m74f88qj9ci8rpyzrbk2slmsdj5ipmwdkq6qk24byalm203li"))
+ (modules '((guix build utils)))
+ (snippet pycryptodome-unbundle-tomcrypt-snippet)))
(build-system python-build-system)
+ (inputs
+ `(("libtomcrypt" ,libtomcrypt)
+ ("libtommath" ,libtommath)))
(home-page "https://www.pycryptodome.org")
(synopsis "Low-level cryptographic Python library")
(description