summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-02 00:47:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:33 -0400
commitc5dd41afc6659b96c86efea512ee7ecc0bbf6604 (patch)
tree984608273e1a1e150e1bb77232b77347e8f4c7c0 /gnu/packages/python-web.scm
parent32ffbb16e8cbb9c5416274320a56885c45a88ebf (diff)
downloadguix-c5dd41afc6659b96c86efea512ee7ecc0bbf6604.tar.gz
guix-c5dd41afc6659b96c86efea512ee7ecc0bbf6604.tar.xz
gnu: Add python-mf2py.
* gnu/packages/python-web.scm (python-mf2py): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 00fe560a36..59828d7473 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7409,3 +7409,35 @@ with @code{html_text} does not contain elements such as JavaScript or inline
styles not normally visible to users. It also normalizes white space
characters in a smarter, more visually pleasing style.")
(license license:expat)))
+
+(define-public python-mf2py
+ (package
+ (name "python-mf2py")
+ (version "1.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/microformats/mf2py")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00pzfc5sl6ywlcr6f2k37n3f2bb7w488p2k95ixzjwx6w3yh747n"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "test")))))))
+ (native-inputs (list python-pytest))
+ (propagated-inputs
+ (list python-beautifulsoup4 python-html5lib python-requests))
+ (home-page "https://github.com/microformats/mf2py")
+ (synopsis "Python Microformats2 parser")
+ (description "This Python library provides a Microformats2 parser
+implementing the full Microformats2 (mf2) specification, including backward
+compatibility with Microformats1 (mf1).")
+ (license license:expat)))