summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-05-22 21:50:37 +0300
committerLudovic Courtès <ludo@gnu.org>2022-06-13 12:27:35 +0200
commitb40761ca9d7107361cf3995d2cee34c0fb3ba39b (patch)
tree57d30eeca43446e0ba448da102c22e820fe1d98f /gnu/packages/python-xyz.scm
parentfcad6226486b52e5d45531f60811d35eac34fa67 (diff)
downloadguix-b40761ca9d7107361cf3995d2cee34c0fb3ba39b.tar.gz
guix-b40761ca9d7107361cf3995d2cee34c0fb3ba39b.tar.xz
gnu: Add python-langcodes.
* gnu/packages/python-xyz.scm (python-langcodes): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b808b710a..f37ca731d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29479,3 +29479,32 @@ Information about these scales can be
@url{https://en.wikipedia.org/wiki/List_of_musical_scales_and_modes, found on
Wikipedia}.")
(license license:expat)))
+
+(define-public python-langcodes
+ (package
+ (name "python-langcodes")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "langcodes" version))
+ (sha256
+ (base32
+ "1xkyh3qdcigb18qiimbwl2669y22hhdmd89mqcd270c7lbahfkbr"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/rspeer/langcodes")
+ (synopsis "Python library for working with language codes")
+ (description
+ "This package provides a Python library for working with and comparing
+language codes.
+
+@code{python-langcodes} implements @url{http://tools.ietf.org/html/bcp47, BCP
+47}, the IETF Best Current Practices on Tags for Identifying Languages. BCP
+47 is also known as RFC 5646. It subsumes ISO 639 and is backward compatible
+with it, and it also implements recommendations from the
+@url{http://cldr.unicode.org/, Unicode CLDR}.
+
+@code{python-langcodes} can also refer to a database of language properties
+and names, built from Unicode CLDR and the IANA subtag registry, if you
+install @code{python-language-data}.")
+ (license license:expat)))