summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-27 22:27:09 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-27 23:06:18 +0100
commite765ad091d861c99eae9fdd402214a2e2e90ed4d (patch)
tree5e1d8cb458deb5e76f0ed73b330cc0c9440de82e /gnu/packages/rust.scm
parent72b0c5a3f221afb824772c4969e85d190a8a3205 (diff)
downloadguix-e765ad091d861c99eae9fdd402214a2e2e90ed4d.tar.gz
guix-e765ad091d861c99eae9fdd402214a2e2e90ed4d.tar.xz
gnu: rust: Add 'supported-systems' field.
* gnu/packages/rust.scm (rust-1.39)[supported-systems]: New field. (rust-1.40)[supported-systems]: Remove.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index f7f05851f1..2a43e88727 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -318,6 +318,11 @@
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")
(home-page "https://github.com/thepowersgang/mrustc")
+
+ ;; So far mrustc is x86_64-only. It may support i686 soon:
+ ;; <https://github.com/thepowersgang/mrustc/issues/78>.
+ (supported-systems '("x86_64-linux"))
+
;; Dual licensed.
(license (list license:asl2.0 license:expat))))
@@ -502,9 +507,6 @@ ar = \"" binutils "/bin/ar" "\"
(search-path-specification
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
- (supported-systems
- (delete "i686-linux" ; fails to build, see bug #35519
- %supported-systems))
(synopsis "Compiler for the Rust progamming language")
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")