summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2019-04-06 08:38:22 +0800
committer宋文武 <iyzsong@member.fsf.org>2019-04-10 19:00:18 +0800
commit9b8df3e8925f80461b20602fc799ec8457a09afc (patch)
tree10eb24666c6c5b7520f67dbf1fb811dd83033895 /gnu/packages/search.scm
parent49cb1cf950035b5c96b7eb3d2490212dfe678b48 (diff)
downloadguix-9b8df3e8925f80461b20602fc799ec8457a09afc.tar.gz
guix-9b8df3e8925f80461b20602fc799ec8457a09afc.tar.xz
gnu: Add perl-search-xapian.
* gnu/packages/search.scm (perl-search-xapian): New variable.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index a127d5ca34..fe51900179 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -23,11 +23,12 @@
(define-module (gnu packages search)
#:use-module ((guix licenses)
- #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11))
+ #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11 perl-license))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
@@ -110,6 +111,31 @@ rich set of boolean query operators.")
(synopsis "Python bindings for the Xapian search engine library")
(license gpl2+)))
+(define-public perl-search-xapian
+ (package
+ (name "perl-search-xapian")
+ (version "1.2.25.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/O/OL/OLLY/"
+ "Search-Xapian-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hpa8gi38j0ibq8af6dy69lm1bl5jnq76nsa69dbrzbr88l5m594"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-devel-leak" ,perl-devel-leak)))
+ (inputs
+ `(("xapian" ,xapian)))
+ (home-page "https://metacpan.org/release/Search-Xapian")
+ (synopsis "Perl XS frontend to the Xapian C++ search library")
+ (description
+ "Search::Xapian wraps most methods of most Xapian classes. The missing
+classes and methods should be added in the future. It also provides a
+simplified, more 'perlish' interface to some common operations.")
+ (license perl-license)))
+
(define-public libtocc
(package
(name "libtocc")