summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2021-10-13 19:01:13 +0200
committerLudovic Courtès <ludo@gnu.org>2021-11-14 00:25:30 +0100
commitd0313cdf5f2288a8884b8550d1381627df209aa6 (patch)
treec0094871d4249ea976ee4e5776538f757e81bae4 /gnu/packages/shellutils.scm
parent704bd694d198ed568349e4772bc6488a58f15d8b (diff)
downloadguix-d0313cdf5f2288a8884b8550d1381627df209aa6.tar.gz
guix-d0313cdf5f2288a8884b8550d1381627df209aa6.tar.xz
gnu: Add renameutils.
* gnu/packages/shellutils.scm (renameutils): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 6e64cee1da..19effc34cc 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2021 Wiktor Żelazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -512,3 +513,32 @@ real person, and are too lazy to think of one yourself. Also, if the Web
site/BBS/person you are giving the information to tries to cross-check the
city, state, zip, or area code, it will check out.")
(license license:gpl2+)))
+
+(define-public renameutils
+ (package
+ (name "renameutils")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://download.savannah.gnu.org/releases/renameutils/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18xlkr56jdyajjihcmfqlyyanzyiqqlzbhrm6695mkvw081g1lnb"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (substitute* "src/Makefile.in"
+ (("\\(\\$bindir\\)") "$(bindir)"))
+ #t))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("readline" ,readline)))
+ (home-page "https://www.nongnu.org/renameutils/")
+ (synopsis "File renaming utilities")
+ (description "The file renaming utilities (renameutils for short) are a set
+of programs designed to make renaming of files faster and less cumbersome. The
+file renaming utilities consists of five programs - qmv, qcp, imv, icp and
+deurlname.")
+ (license license:gpl3)))