summaryrefslogtreecommitdiff
path: root/gnu/packages/stalonetray.scm
diff options
context:
space:
mode:
authorRaimon Grau <raimonster@gmail.com>2014-02-09 16:28:39 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-09 22:06:15 +0100
commit4cccb3617ee0e2344d0d986f3c60d97e77aa3249 (patch)
tree7a600583eae5a5c9deed9e83a5a5b1391c0a49d6 /gnu/packages/stalonetray.scm
parent350b9b9933bdfd46efd3e9dee6f1dd1ec5889818 (diff)
downloadguix-4cccb3617ee0e2344d0d986f3c60d97e77aa3249.tar.gz
guix-4cccb3617ee0e2344d0d986f3c60d97e77aa3249.tar.xz
gnu: Add stalonetray
* gnu/packages/stalonetray.scm: New file * gnu-system.am (GNU_SYSTEM_MODULES): Add stalonetray.scm Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/stalonetray.scm')
-rw-r--r--gnu/packages/stalonetray.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/stalonetray.scm b/gnu/packages/stalonetray.scm
new file mode 100644
index 0000000000..5a53cd832e
--- /dev/null
+++ b/gnu/packages/stalonetray.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages stalonetray)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module (gnu packages xorg))
+
+(define-public stalonetray
+ (package
+ (name "stalonetray")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/stalonetray/stalonetray-"
+ version "/stalonetray-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1wp8pnlv34w7xizj1vivnc3fkwqq4qgb9dbrsg15598iw85gi8ll"))))
+ (inputs `(("libx11" ,libx11)))
+ (build-system gnu-build-system)
+ (home-page "stalonetray")
+ (synopsis "Standalone freedesktop.org and KDE systray implementation")
+ (description
+ "Stalonetray is a stand-alone freedesktop.org and KDE system
+tray (notification area) for X Window System/X11 (e.g. X.Org or XFree86). It
+has full XEMBED support and minimal dependencies: an X11 lib only. Stalonetray
+works with virtually any EWMH-compliant window manager.")
+ (license gpl2+)))