summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-01-24 11:11:11 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-01-28 12:34:04 +0200
commitff0ff69315fa2cffa224b6f4b2f879a8e0bdbb89 (patch)
tree83e76d1fffe119b09d040b3a79a837726157f698 /gnu/packages/syndication.scm
parenta929ede800b4d8c0966a1dee425a0c56014dce30 (diff)
downloadguix-ff0ff69315fa2cffa224b6f4b2f879a8e0bdbb89.tar.gz
guix-ff0ff69315fa2cffa224b6f4b2f879a8e0bdbb89.tar.xz
gnu: liferea: Add missing inputs.
These new inputs are referenced by the package but was missing in the package definition. Some of these inputs might have been used by the package indirectly via propagation from other inputs. * gnu/packages/syndication.scm (liferea) [inputs]: Add glib, libsoup, pango and sqlite. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index d191d21999..0e33f99910 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -225,7 +225,8 @@ file system, and many more features.")
("pkg-config" ,pkg-config)
("which" ,which)))
(inputs
- `(("glib-networking" ,glib-networking)
+ `(("glib" ,glib)
+ ("glib-networking" ,glib-networking)
("gnome-keyring" ,gnome-keyring)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gstreamer" ,gstreamer)
@@ -233,11 +234,14 @@ file system, and many more features.")
("libnotify" ,libnotify)
("libpeas" ,libpeas)
("libsecret" ,libsecret)
+ ("libsoup" ,libsoup)
("libxml2" ,libxml2)
("libxslt" ,libxslt)
+ ("pango" ,pango)
("python" ,python)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
+ ("sqlite" ,sqlite)
("webkitgtk" ,webkitgtk)))
(home-page "https://lzone.de/liferea/")
(synopsis "News reader for GTK/GNOME")