summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-08 12:05:37 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-08 12:14:37 +0200
commit0f9d02f1685c1fdc654a52c544ca6d9b44cd2118 (patch)
tree1f31d507f75804df4770f8c7fe6a93a067e96b10 /gnu/packages/tex.scm
parent5c03615700ee7b4c47a463d24c910f34f109a732 (diff)
downloadguix-0f9d02f1685c1fdc654a52c544ca6d9b44cd2118.tar.gz
guix-0f9d02f1685c1fdc654a52c544ca6d9b44cd2118.tar.xz
gnu: texlive-psnfss: Incorporate and remove replacement.
* gnu/packages/tex.scm (texlive-psnfss)[replacement]: Remove. [arguments]: Add 'unchdir' and 'delete-extra-files' phases. (texlive-psnfss/fixed): Remove.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 9 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 65a3f29a7f..96449a7492 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4139,8 +4139,6 @@ language that is written in a Cyrillic alphabet.")
"11f14dzhwsy4pli21acccip43d36nf3pac33ihjffnps1i2mhqkd"))))
(package
(inherit template)
- ;; TODO: This package is missing files.
- (replacement texlive-psnfss/fixed)
(arguments
(substitute-keyword-arguments (package-arguments template)
((#:tex-directory _ #t)
@@ -4149,7 +4147,15 @@ language that is written in a Cyrillic alphabet.")
`(modify-phases ,phases
(add-after 'unpack 'chdir
(lambda _
- (chdir "source/latex/psnfss") #t))))))
+ (chdir "source/latex/psnfss")))
+ (add-before 'copy-files 'unchdir
+ (lambda _
+ (chdir "../../..")))
+ (add-after 'copy-files 'delete-extra-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/source/latex/psnfss/build"))))))))
(native-inputs
(list texlive-cm))
(home-page "https://www.ctan.org/pkg/psnfss")
@@ -4168,23 +4174,6 @@ means to select single glyphs from symbol fonts. The bundle as a whole is
part of the LaTeX required set of packages.")
(license license:lppl1.2+))))
-(define-public texlive-psnfss/fixed
- (package
- (inherit texlive-psnfss)
- (name "texlive-psnfss-fixed")
- (arguments
- (substitute-keyword-arguments (package-arguments texlive-psnfss)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'copy-files 'unchdir
- (lambda _
- (chdir "../../..")))
- (add-after 'copy-files 'delete-extra-files
- (lambda* (#:key outputs #:allow-other-keys)
- (delete-file-recursively
- (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/source/latex/psnfss/build"))))))))))
-
(define-deprecated-package texlive-latex-psnfss texlive-psnfss)
;; For user profiles