summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-31 22:46:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:23 -0400
commit5d40463875703b2aca792bb60581eda2b8f82bbf (patch)
tree09e17737e9af27355b0539da0a6a024927c5a505 /gnu/packages/tex.scm
parent92f573f63aadb597031c991adfffe1031e393f89 (diff)
downloadguix-5d40463875703b2aca792bb60581eda2b8f82bbf.tar.gz
guix-5d40463875703b2aca792bb60581eda2b8f82bbf.tar.xz
gnu: Add texlive-csplain.
* gnu/packages/tex.scm (texlive-csplain): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 40390e9970..f8fa65e386 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4081,6 +4081,34 @@ polyglossia package rather than Babel.")
(define-deprecated-package texlive-latex-babel texlive-babel)
+;;; Note: if this package is modified, its name must be changed to comply with
+;;; its license.
+(define-public texlive-csplain
+ (package
+ (inherit (simple-texlive-package
+ "texlive-csplain"
+ (list "tex/csplain/base/")
+ (base32 "0cgrwc8lgf2x2hq6bb4kqxw597card985zdd9ipn7k98mmwrxhz3")
+ #:trivial? #t))
+ (home-page "http://petr.olsak.net/csplain-e.html")
+ (synopsis "Plain TeX multilanguage support")
+ (description "CSplain is a small extension of basic Plain TeX macros from
+which the formats @code{csplain} and @code{pdfcsplain} can be generated. It
+supports: hyphenation of words for 50+ languages, simple and powerful font
+loading system (various sizes of fonts), TeX, pdfTeX, XeTeX and LuaTeX
+engines, math fonts simply loaded with full amstex-like features, three
+internal encodings (IL2 for Czech/Slovak languages, T1 for many languages with
+latin alphabet and Unicode in new TeX engines), natural UTF-8 input in pdfTeX
+using encTeX without any active characters, Czech and Slovak special
+typesetting features. An important part of the package is OPmac, which
+implements most of LaTeX's features (sectioning, font selection, color, hyper
+reference and URLs, bibliography, index, table of contents, tables, etc.) by
+Plain TeX macros. The OPmac macros can generate a bibliography without any
+external program.")
+ ;; This custom permissive license includes as a redistribution condition
+ ;; that says the package must be renamed from 'csplain' if it is modified.
+ (license (license:non-copyleft "file:///tex/csplain/base/csplain.ini"))))
+
(define-public texlive-generic-babel-english
(package
(name "texlive-generic-babel-english")