summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-31 01:30:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:22 -0400
commitce73cadd34b6e49a1e6fd0d7b98048e7867f799b (patch)
tree9723380768b4f67cb2cc125ad8c80b83571e3960 /gnu/packages/tex.scm
parent7cab14c3363ae8ccdcec5b67bdad645eabd6b792 (diff)
downloadguix-ce73cadd34b6e49a1e6fd0d7b98048e7867f799b.tar.gz
guix-ce73cadd34b6e49a1e6fd0d7b98048e7867f799b.tar.xz
gnu: Add texlive-paralist.
* gnu/packages/tex.scm (texlive-paralist): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 46 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 34e9aa1e06..8c31d131b6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
@@ -5417,6 +5417,51 @@ which adds some minor changes to LaTeX maths; a rewrite of LaTeX's tabular and
array environments; verbatim handling; and syntax diagrams.")
(license license:gpl3+)))
+(define-public texlive-paralist
+ (package
+ (inherit (simple-texlive-package
+ "texlive-paralist"
+ (list "doc/latex/paralist/README"
+ "source/latex/paralist/paralist.dtx"
+ "source/latex/paralist/paralist.ins")
+ (base32 "1lz8yds2i64wkb89a9amydwkzsdbc09s1kbgn7vgh2qsxqrrgwam")))
+ (outputs '("out" "doc"))
+ (arguments
+ (list
+ #:tex-directory "latex/paralist"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'chdir
+ (lambda _
+ (setenv "ROOT_DIR" (getcwd))
+ (chdir "source/latex/paralist")))
+ (add-after 'build 'build-doc
+ (lambda* (#:key outputs tex-directory #:allow-other-keys)
+ (copy-file "paralist.dtx" "build/paralist.dtx")
+ (chdir "build")
+ (invoke "pdflatex" "paralist.dtx")))
+ (replace 'install
+ (lambda* (#:key outputs tex-directory #:allow-other-keys)
+ (let ((doc (string-append (assoc-ref outputs "doc")
+ "/share/doc/" tex-directory))
+ (out (string-append #$output "/share/texmf-dist/tex/"
+ tex-directory)))
+ (install-file "paralist.pdf" doc)
+ (install-file (car (find-files (getenv "ROOT_DIR") "README"))
+ doc)
+ (install-file "paralist.sty" out)))))))
+ (native-inputs (list texlive-latex-base
+ (texlive-updmap.cfg
+ (list texlive-cm
+ texlive-jknappen))))
+ (home-page "https://ctan.org/pkg/paralist")
+ (synopsis "Enumerate and itemize within paragraphs")
+ (description "The @code{paralist} package provides enumerate and itemize
+environments that can be used within paragraphs to format the items either as
+running text or as separate paragraphs with a preceding number or symbol. It
+also provides compacted versions of enumerate and itemize.")
+ (license license:lppl1.0+)))
+
(define-public texlive-latex-polyglossia
(package
(name "texlive-latex-polyglossia")