summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-08 12:02:30 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-08 12:14:37 +0200
commitcf14b81b7e79a96862702d97b82409096a675b0b (patch)
tree6e89e04b1f796f22cc98397906aa179301c3972d /gnu/packages/tex.scm
parent3aafcdbd8ba2fdec961fd8e7d7c892e20caf4787 (diff)
downloadguix-cf14b81b7e79a96862702d97b82409096a675b0b.tar.gz
guix-cf14b81b7e79a96862702d97b82409096a675b0b.tar.xz
gnu: texlive-babel: Incorporate and remove replacement.
* gnu/packages/tex.scm (texlive-babel)[replacement]: Remove. [arguments]: Add 'unchdir' and 'delete-extra-files' phases. (texlive-babel/fixed): Remove.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 14 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 76cc0f7119..647229bdb8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3855,8 +3855,6 @@ distribution.")
"0qr5vjp79g1c1l6k173qhfdfabgbky73wymzhm56pazx4a8r08wz"))))
(package
(inherit template)
- ;; TODO: This package is missing files.
- (replacement texlive-babel/fixed)
(arguments
(substitute-keyword-arguments (package-arguments template)
((#:tex-directory _ #t)
@@ -3872,6 +3870,20 @@ distribution.")
(substitute* "babel.ins"
(("askonceonly") "askforoverwritefalse"))
#t))
+ (add-before 'copy-files 'unchdir
+ (lambda _
+ (chdir "../../..")))
+ (add-after 'copy-files 'delete-extra-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/source/latex/babel/build"))
+ (delete-file
+ (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/tex/generic/babel/bbind.ist"))
+ (delete-file
+ (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/tex/generic/babel/bbglo.ist"))))
(add-after 'install 'install-locales
(lambda* (#:key outputs #:allow-other-keys)
(let ((locale-directory
@@ -3894,29 +3906,6 @@ what has to be done for each language. Users of XeTeX are advised to use the
polyglossia package rather than Babel.")
(license license:lppl1.3+))))
-(define-public texlive-babel/fixed
- (package
- (inherit texlive-babel)
- (name "texlive-babel-fixed")
- (arguments
- (substitute-keyword-arguments (package-arguments texlive-babel)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'copy-files 'unchdir
- (lambda _
- (chdir "../../..")))
- (add-after 'copy-files 'delete-extra-files
- (lambda* (#:key outputs #:allow-other-keys)
- (delete-file-recursively
- (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/source/latex/babel/build"))
- (delete-file
- (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/tex/generic/babel/bbind.ist"))
- (delete-file
- (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/tex/generic/babel/bbglo.ist"))))))))))
-
(define-deprecated-package texlive-latex-babel texlive-babel)
(define-public texlive-generic-babel-english