summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 23:21:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:49 -0400
commitcf44f00b5b64ef7908629e049561f58aadc407d9 (patch)
tree09702557574b5af18584ec9b910ee8b8aaebdd01 /gnu/packages/tex.scm
parente2c570003225200965c4485b73833e69ddd444ce (diff)
downloadguix-cf44f00b5b64ef7908629e049561f58aadc407d9.tar.gz
guix-cf44f00b5b64ef7908629e049561f58aadc407d9.tar.xz
gnu: Add texlive-cm-lgc.
* gnu/packages/tex.scm (texlive-cm-lgc): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c0b874faec..994f03987e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1028,6 +1028,31 @@ display, and mathematical fonts in a range of styles, based on Monotype Modern
(define-deprecated-package texlive-fonts-cm texlive-cm)
+(define-public texlive-cm-lgc
+ (package
+ (inherit (simple-texlive-package
+ "texlive-cm-lgc"
+ (list "/doc/fonts/cm-lgc/"
+ "/fonts/afm/public/cm-lgc/"
+ "/fonts/type1/public/cm-lgc/"
+ "/fonts/vf/public/cm-lgc/"
+ "/tex/latex/cm-lgc/")
+ (base32
+ "0rm7wgyb07y8h6vbvc2xzsqnxy322d4j9ly2p67z84b81c8i3zpc")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/cm-lgc")
+ (synopsis "Type 1 CM-based fonts for Latin, Greek and Cyrillic")
+ (description "The fonts are converted from Metafont sources of the
+Computer Modern font families, using @command{textrace}. Supported encodings
+are: T1 (Latin), T2A (Cyrillic), LGR (Greek) and TS1. The package also
+includes Unicode virtual fonts for use with Omega. The font set is not a
+replacement for any of the other Computer Modern-based font sets (for example,
+cm-super for Latin and Cyrillic, or cbgreek for Greek), since it is available
+at a single size only; it offers a compact set for @i{general} working. The
+fonts themselves are encoded to external standards, and virtual fonts are
+provided for use with TeX.")
+ (license license:gpl2+)))
+
(define-public texlive-cm-super
(let ((template (simple-texlive-package
"texlive-cm-super"