summaryrefslogtreecommitdiff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-27 10:16:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-27 11:42:38 +0300
commit5fd84e288cac9a7ddfea9810f6459b02b9f2f86d (patch)
tree751210f827f3800e8ca5a81ad3a09a48db8c1ac6 /gnu/packages/valgrind.scm
parente68168eb87cdc95fa97dc5aab0c03bd1633cd67b (diff)
downloadguix-5fd84e288cac9a7ddfea9810f6459b02b9f2f86d.tar.gz
guix-5fd84e288cac9a7ddfea9810f6459b02b9f2f86d.tar.xz
gnu: valgrind: Use 'modify-phases' syntax.
* gnu/packages/valgrind.scm (valgrind)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 55ae88641c..5f2bef16df 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,18 +42,18 @@
(patches (search-patches "valgrind-enable-arm.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-after
- 'install 'patch-suppression-files
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Don't assume the FHS.
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/lib/valgrind")))
- (substitute* (find-files dir "\\.supp$")
- (("obj:/lib") "obj:*/lib")
- (("obj:/usr/X11R6/lib") "obj:*/lib")
- (("obj:/usr/lib") "obj:*/lib"))
- #t))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'patch-suppression-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Don't assume the FHS.
+ (let* ((out (assoc-ref outputs "out"))
+ (dir (string-append out "/lib/valgrind")))
+ (substitute* (find-files dir "\\.supp$")
+ (("obj:/lib") "obj:*/lib")
+ (("obj:/usr/X11R6/lib") "obj:*/lib")
+ (("obj:/usr/lib") "obj:*/lib"))
+ #t))))))
(inputs `(;; GDB is needed to provide a sane default for `--db-command'.
("gdb" ,gdb)))
(native-inputs `(("perl" ,perl)))