summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-05 19:11:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-05 19:14:14 +0200
commit2e97761efe4816df4604870c2c85c90725969de2 (patch)
tree76612810dee0b658fd173ba0e01c1a4109a308f2 /gnu/packages/wget.scm
parentc107a30bb48cda91fba502e862a1b426d475cb19 (diff)
downloadguix-2e97761efe4816df4604870c2c85c90725969de2.tar.gz
guix-2e97761efe4816df4604870c2c85c90725969de2.tar.xz
gnu: wgetpaste: Build from Git.
* gnu/packages/wget.scm (wgetpaste)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 70022f6c90..3d7f266dd7 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -39,6 +39,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu))
(define-public wget
@@ -80,11 +81,13 @@ in downloaded documents to relative links.")
(version "2.30")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://wgetpaste.zlin.dk/wgetpaste-"
- version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zlin/wgetpaste")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "14k5i6j6f34hcf9gdb9cnvfwscn0ys2dgd73ci421wj9zzqkbv73"))
+ (base32 "0fhm0qxdsm4k1m24z4bbb7mdv1x1iaqzgsnwkax6vb8bx9yd1ysi"))
(patches (search-patches "wgetpaste-update-bpaste.patch"))))
(build-system gnu-build-system)
(arguments