summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:31:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:42:04 +0300
commit64c043e63a4be97f59fd1906c47973a74eedda67 (patch)
tree37b15dfb4830e4f874edca87b521b6e9cdc3c81b /gnu/packages/wget.scm
parentb1f763de54dc2b8e240d0f01f7948ce76f67243e (diff)
parent75af73e1b7ac58770122d8831faa3a8158638bb0 (diff)
downloadguix-64c043e63a4be97f59fd1906c47973a74eedda67.tar.gz
guix-64c043e63a4be97f59fd1906c47973a74eedda67.tar.xz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm95
1 files changed, 45 insertions, 50 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index ec655b95bd..73338c73b3 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -25,6 +25,7 @@
(define-module (gnu packages wget)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gnunet)
@@ -45,7 +46,7 @@
(define-public wget
(package
(name "wget")
- (version "1.21.1")
+ (version "1.21.3")
(source
(origin
(method url-fetch)
@@ -53,7 +54,7 @@
version ".tar.lz"))
(sha256
(base32
- "1bchzkacjsc5c0x01ngaana9fs5j12wfw1c8qxps1yp68x9vx6yv"))))
+ "19afmyr1i3zwdwr8wkyz8q6z5764ik3dm87as194g78l8xggplnv"))))
(build-system gnu-build-system)
(inputs
(list gnutls libidn2 libpsl))
@@ -100,16 +101,14 @@ in downloaded documents to relative links.")
(substitute* "wgetpaste"
;; dpaste blocks Tor users. Use a better default.
(("DEFAULT_SERVICE:-dpaste")
- "DEFAULT_SERVICE-bpaste"))
- #t))
+ "DEFAULT_SERVICE-bpaste"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(zsh (string-append out "/share/zsh/site-functions")))
(install-file "wgetpaste" bin)
- (install-file "_wgetpaste" zsh)
- #t)))
+ (install-file "_wgetpaste" zsh))))
(add-after 'install 'wrap-program
;; /bin/wgetpaste prides itself on relying only on the following
;; inputs, and doesn't need to execute arbitrary commands, so
@@ -121,11 +120,10 @@ in downloaded documents to relative links.")
,(delete-duplicates
(map (lambda (command) (dirname (which command)))
(list "bash" "mktemp" "sed" "sort" "tee" "tr"
- "wget" "xclip")))))
- #t))))
+ "wget" "xclip")))))))))
#:tests? #f)) ; no test target
(inputs
- (list wget xclip))
+ (list bash-minimal wget xclip))
(home-page "https://wgetpaste.zlin.dk/")
(synopsis "Script that automates pasting to a number of pastebin services")
(description
@@ -135,43 +133,40 @@ online pastebin services.")
(define-public wget2
(package
- (name "wget2")
- (version "2.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/wget/wget2-" version ".tar.gz"))
- (sha256
- (base32
- "0i0m4k6w9smsr2m5mj05zvl1fb110izyl2qqrk0yqlxnmfhgpqjg"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-network-tests
- (lambda _
- (substitute* "tests/Makefile.in"
- (("test-gpg-verify-no-file\\$\\(EXEEXT)") "")
- (("test-gpg-valid\\$\\(EXEEXT)") "")
- (("test-gpg-styles\\$\\(EXEEXT)") ""))
- #t)))
- #:configure-flags '("--enable-static=no")))
- (inputs
- (list bzip2
- gnutls/dane
- gpgme
- libidn2
- libmicrohttpd
- libpsl
- pcre2
- zlib))
- ;; TODO: Add libbrotlidec, libnghttp2.
- (native-inputs
- (list pkg-config))
- (home-page "https://gitlab.com/gnuwget/wget2")
- (synopsis "Successor of GNU Wget")
- (description "GNU Wget2 is the successor of GNU Wget, a file and recursive
-website downloader. Designed and written from scratch it wraps around libwget,
-that provides the basic functions needed by a web client.")
- (properties '((ftp-directory . "/gnu/wget")))
- (license (list license:gpl3+ license:lgpl3+))))
+ (name "wget2")
+ (version "2.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/wget/wget2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1caxhkwk08z3npzw8x2qhkmjc224cfw1aphvbv8bidbvd41zmdqb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'skip-network-tests
+ (lambda _
+ (substitute* "tests/Makefile.in"
+ (("test-gpg-verify-no-file\\$\\(EXEEXT)") "")
+ (("test-gpg-valid\\$\\(EXEEXT)") "")
+ (("test-gpg-styles\\$\\(EXEEXT)") "")))))
+ #:configure-flags
+ '("--enable-static=no")))
+ (inputs (list bzip2
+ gnutls/dane
+ gpgme
+ libidn2
+ libmicrohttpd
+ libpsl
+ pcre2
+ zlib))
+ ;; TODO: Add libbrotlidec, libnghttp2.
+ (native-inputs (list pkg-config))
+ (home-page "https://gitlab.com/gnuwget/wget2")
+ (synopsis "Successor of GNU Wget")
+ (description
+ "GNU Wget2 is the successor of GNU Wget, a file and recursive website
+downloader. Designed and written from scratch it wraps around libwget, that
+provides the basic functions needed by a web client.")
+ (properties '((ftp-directory . "/gnu/wget")))
+ (license (list license:gpl3+ license:lgpl3+))))