summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-09 15:28:16 +0000
committerLeo Famulari <leo@famulari.name>2021-10-16 17:32:24 -0400
commit87535cbc9876295fac84c1c5be6a2ec1f72e96fb (patch)
tree808eb693b41e90df4a1adbd79409189f14e6e12f /gnu/packages/xiph.scm
parentf2acd45eae3697c798716e6b99c32565babbf70f (diff)
downloadguix-87535cbc9876295fac84c1c5be6a2ec1f72e96fb.tar.gz
guix-87535cbc9876295fac84c1c5be6a2ec1f72e96fb.tar.xz
gnu: opusfile: Fix Opus header lookups.
* gnu/packages/xiph.scm (opusfile)[arguments]<#:phases>: Add a 'fix-multistream' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index fbbcbd6e61..0c9c799067 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -406,7 +407,16 @@ decoding .opus files.")
"02smwc5ah8nb3a67mnkjzqmrzk43j356hgj2a97s9midq40qd38i"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ '(#:configure-flags '("--disable-static")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-multistream
+ ;; Opus include directory should be passed explicitly:
+ ;; https://github.com/xiph/opusfile/issues/10 however,
+ ;; opus_multistream.h still can't be found by the compiler.
+ (lambda _
+ (substitute* "include/opusfile.h"
+ (("opus_multistream\\.h") "opus/opus_multistream.h")))))))
;; Required by opusfile.pc and opusurl.pc.
(propagated-inputs
`(("libogg" ,libogg)