summaryrefslogtreecommitdiff
path: root/gnu/packages/zile.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-07-08 17:12:26 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 17:12:26 +0200
commitbeaa5dff38db8c31a99d7f4484864b12c838b4e2 (patch)
treebf96fcc0a36585e7573a1a7fc08da355a7e20e94 /gnu/packages/zile.scm
parent57a747e15a9071e7e41bb1871a8f2d1938b03889 (diff)
downloadguix-beaa5dff38db8c31a99d7f4484864b12c838b4e2.tar.gz
guix-beaa5dff38db8c31a99d7f4484864b12c838b4e2.tar.xz
gnu: zile-on-guile: Fix build.
This is a follow-up of da40d07066096a3b5a852041ea01fbb32240deda. * gnu/packages/zile.scm (zile-on-guile)[arguments]: Restore the original patch-/bin/sh phase.
Diffstat (limited to 'gnu/packages/zile.scm')
-rw-r--r--gnu/packages/zile.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/zile.scm b/gnu/packages/zile.scm
index bd5b1e80b0..bb9270968c 100644
--- a/gnu/packages/zile.scm
+++ b/gnu/packages/zile.scm
@@ -149,6 +149,14 @@ default Emacs configuration, but it carries a much lighter feature set.")
"--gnulib-srcdir=gnulib"
"--skip-git" "--skip-po"
"--verbose")))
+ (replace 'patch-/bin/sh
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ ;; Refer to the actual shell.
+ (substitute* '("lib/spawni.c" "src/funcs.c")
+ (("/bin/sh")
+ (string-append bash "/bin/sh")))
+ #t)))
(add-after 'install 'wrap-command
(lambda* (#:key outputs #:allow-other-keys)
;; Add zile.scm to the search path.