summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2019-11-27 18:04:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-27 18:15:34 +0100
commit9bd56b1a77e7011a044e9da6d4f7a00226eb01e0 (patch)
tree3fbfc0b427daef7ce182ef8d0dcf59f90ee6dde4 /gnu
parent0eb59d9eac63068f382cf3fe6c0d4dd867c6256c (diff)
downloadguix-9bd56b1a77e7011a044e9da6d4f7a00226eb01e0.tar.gz
guix-9bd56b1a77e7011a044e9da6d4f7a00226eb01e0.tar.xz
gnu: r-desolve: Move to (gnu packages cran).
* gnu/packages/maths.scm (r-desolve): Move from here... * gnu/packages/cran.scm (r-desolve): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
-rw-r--r--gnu/packages/maths.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 62113ab7e0..943cd0deec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15761,3 +15761,31 @@ data.table.")
"This package contains routines and documentation for solving quadratic
programming problems.")
(license license:gpl3+)))
+
+(define-public r-desolve
+ (package
+ (name "r-desolve")
+ (version "1.25")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "deSolve" version))
+ (sha256
+ (base32 "0735y3p5glhqx69rzrc8qgmvs7p7w0p98qxmvylb6bgqp6kp0cbp"))))
+ (properties `((upstream-name . "deSolve")))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://desolve.r-forge.r-project.org/")
+ (synopsis "Solvers for initial value problems of differential equations")
+ (description "This package provides functions that solve initial
+value problems of a system of first-order ordinary differential equations (ODE),
+of partial differential equations (PDE), of differential algebraic equations
+(DAE), and of delay differential equations. The functions provide an interface
+to the FORTRAN functions lsoda, lsodar, lsode, lsodes of the ODEPACK collection,
+to the FORTRAN functions dvode and daspk and a C-implementation of solvers of
+the Runge-Kutta family with fixed or variable time steps. The package contains
+routines designed for solving ODEs resulting from 1-D, 2-D and 3-D partial
+differential equations (PDE) that have been converted to ODEs by numerical
+differencing.")
+ (license license:gpl2+)))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cf78d0b7a4..9108150de9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4384,34 +4384,6 @@ subspaces. The method is well suited for optimizing objective functions that
are noisy or are discontinuous at the solution.")
(license license:gpl3+)))
-(define-public r-desolve
- (package
- (name "r-desolve")
- (version "1.25")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "deSolve" version))
- (sha256
- (base32 "0735y3p5glhqx69rzrc8qgmvs7p7w0p98qxmvylb6bgqp6kp0cbp"))))
- (properties `((upstream-name . "deSolve")))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (home-page "https://desolve.r-forge.r-project.org/")
- (synopsis "Solvers for initial value problems of differential equations")
- (description "This package provides functions that solve initial
-value problems of a system of first-order ordinary differential equations (ODE),
-of partial differential equations (PDE), of differential algebraic equations
-(DAE), and of delay differential equations. The functions provide an interface
-to the FORTRAN functions lsoda, lsodar, lsode, lsodes of the ODEPACK collection,
-to the FORTRAN functions dvode and daspk and a C-implementation of solvers of
-the Runge-Kutta family with fixed or variable time steps. The package contains
-routines designed for solving ODEs resulting from 1-D, 2-D and 3-D partial
-differential equations (PDE) that have been converted to ODEs by numerical
-differencing.")
- (license license:gpl2+)))
-
(define-public tcalc
(package
(name "tcalc")