summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-11-27 18:36:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-27 18:36:39 +0100
commitdcc7fad0016d7ef062ccfe0b1deb3368251e8ff8 (patch)
tree34664638810b70cf0201cb3c352a538006e714aa /gnu
parentf3640e7395b54c801bde8ba40ad08bdad488453d (diff)
downloadguix-dcc7fad0016d7ef062ccfe0b1deb3368251e8ff8.tar.gz
guix-dcc7fad0016d7ef062ccfe0b1deb3368251e8ff8.tar.xz
gnu: r-txtplot: Move to (gnu packages cran).
* gnu/packages/statistics.scm (r-txtplot): Move from here... * gnu/packages/cran.scm (r-txtplot): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
-rw-r--r--gnu/packages/statistics.scm20
2 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0797897acd..f2da9ca88a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Eric Brown <brown@fastmail.com>
;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
@@ -15830,3 +15831,23 @@ It solves unconstrained optimization problems using a simplex method on
subspaces. The method is well suited for optimizing objective functions that
are noisy or are discontinuous at the solution.")
(license license:gpl3+)))
+
+(define-public r-txtplot
+ (package
+ (name "r-txtplot")
+ (version "1.0-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "txtplot" version))
+ (sha256
+ (base32
+ "1949ab1bzvysdb79g8x1gaknj0ih3d6g63pv9512h5m5l3a6c31h"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/txtplot/")
+ (synopsis "Text-based plotting")
+ (description "This package provides functions to produce rudimentary ASCII
+graphics directly in the terminal window. This package provides a basic
+plotting function (and equivalents of curve, density, acf and barplot) as well
+as a boxplot function.")
+ (license license:lgpl3+)))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index c7860d2ea1..1c315c23ef 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5710,26 +5710,6 @@ table made by the command @code{show256Colors()}. You can also set the colors
to any arbitrary string. In this case, it is up to you to set valid values.")
(license license:gpl3+)))
-(define-public r-txtplot
- (package
- (name "r-txtplot")
- (version "1.0-3")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "txtplot" version))
- (sha256
- (base32
- "1949ab1bzvysdb79g8x1gaknj0ih3d6g63pv9512h5m5l3a6c31h"))))
- (build-system r-build-system)
- (home-page "https://cran.r-project.org/web/packages/txtplot/")
- (synopsis "Text-based plotting")
- (description "This package provides functions to produce rudimentary ASCII
-graphics directly in the terminal window. This package provides a basic
-plotting function (and equivalents of curve, density, acf and barplot) as well
-as a boxplot function.")
- (license license:lgpl3+)))
-
(define-public python-rpy2
;; We need to take this changeset instead of the RELEASE_3_0_4 tag, because
;; it fixes a regression when using ggplot 3.2.0.