summaryrefslogtreecommitdiff
path: root/guix/licenses.scm
diff options
context:
space:
mode:
authorHelio Machado <0x2b3bfa0+git@googlemail.com>2020-10-15 18:32:59 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-17 22:40:18 +0200
commitf045a7a9262c0291175533c92cdd73e43d5e2f6b (patch)
tree07f5b13841726f63bd0878229ec6bc9c008b7d11 /guix/licenses.scm
parent21fdf429a7bb6a7d371fcf1d5b5a892fb9c5cdfc (diff)
downloadguix-f045a7a9262c0291175533c92cdd73e43d5e2f6b.tar.gz
guix-f045a7a9262c0291175533c92cdd73e43d5e2f6b.tar.xz
import: utils: Fix license name mismatches and define CUA-OPL-1.0.
* guix/licenses.scm (cua-opl1.0): New variable. * guix/import/utils.scm (spdx-string->license): Rename licenses to fit the internal names and add a notice pointing to guix/licenses.scm. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/licenses.scm')
-rw-r--r--guix/licenses.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/guix/licenses.scm b/guix/licenses.scm
index cd43386102..255b755e6c 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 André Batista <nandre@riseup.net>
+;;; Copyright © 2020 Helio Machado <0x2b3bfa0+guix@googlemail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,6 +50,7 @@
artistic2.0 clarified-artistic
copyleft-next
cpl1.0
+ cua-opl1.0
edl1.0
epl1.0
epl2.0
@@ -117,6 +119,9 @@
;;; https://github.com/NixOS/nixpkgs/blob/master/lib/licenses.nix
;;; https://www.gnu.org/licenses/license-list
;;;
+;;; Please update spdx-string->license from guix/import/utils.scm
+;;; when modifying this list to avoid mismatches.
+;;;
;;; Code:
(define agpl1
@@ -269,6 +274,11 @@ at URI, which may be a file:// URI pointing the package's tree."
"http://directory.fsf.org/wiki/License:CPLv1.0"
"https://www.gnu.org/licenses/license-list#CommonPublicLicense10"))
+(define cua-opl1.0
+ (license "CUA Office Public License v1.0"
+ "https://spdx.org/licenses/CUA-OPL-1.0.html"
+ "https://opensource.org/licenses/CUA-OPL-1.0"))
+
(define edl1.0
(license "EDL 1.0"
"http://directory.fsf.org/wiki/License:EDLv1.0"