summaryrefslogtreecommitdiff
path: root/guix/upstream.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-03-04 19:32:32 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:34 +0200
commit0d9f1f15cb0ce1e71943bff9a68e6839d0eae497 (patch)
tree448fb02a1b01282e1118e4115ff528a13687f656 /guix/upstream.scm
parent97586ca1cb25aed9da13c9cc7de152346be0a093 (diff)
downloadguix-0d9f1f15cb0ce1e71943bff9a68e6839d0eae497.tar.gz
guix-0d9f1f15cb0ce1e71943bff9a68e6839d0eae497.tar.xz
import: Add hex.pm importer.
hex.pm is a package repository for Erlang and Elixir. * guix/scripts/import.scm (importers): Add "hexpm". * guix/scripts/import/hexpm.scm, guix/import/hexpm.scm, guix/hexpm-download.scm: New files. * guix/import/utils.scm (source-spec->object): Add "hexpm-fetch" to list of fetch methods. * guix/upstream.scm (package-update/hexpm-fetch): New function. (%method-updates) Add it. * Makefile.am: Add them.
Diffstat (limited to 'guix/upstream.scm')
-rw-r--r--guix/upstream.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/guix/upstream.scm b/guix/upstream.scm
index 6666803a92..b0f77fb7d0 100644
--- a/guix/upstream.scm
+++ b/guix/upstream.scm
@@ -464,6 +464,7 @@ SOURCE, an <upstream-source>."
#:key-download key-download)))
(values version tarball source))))))
+
(define* (package-update/git-fetch store package source #:key key-download)
"Return the version, checkout, and SOURCE, to update PACKAGE to
SOURCE, an <upstream-source>."