summaryrefslogtreecommitdiff
path: root/tests/base32.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-08-29 12:33:21 +0200
committerLudovic Courtès <ludo@gnu.org>2020-08-29 16:24:17 +0200
commitd7965b58d25c9c7648ba5682223f32d759fdffda (patch)
tree770dce17ca9abe35b52d30c14e8fe67dbc9e872e /tests/base32.scm
parentf5d3a1690cb78ce9413b78352f1030bf4801617a (diff)
downloadguix-d7965b58d25c9c7648ba5682223f32d759fdffda.tar.gz
guix-d7965b58d25c9c7648ba5682223f32d759fdffda.tar.xz
build: Remove references to the 'nix-hash' program.
* configure.ac: Remove check for 'nix-hash'. * tests/base32.scm (%nix-hash, %have-nix-hash?): Remove. ("sha256 & bytevector->nix-base32-string"): Remove test. * build-aux/pre-inst-env.in: Do not set 'NIX_HASH' environment variable.
Diffstat (limited to 'tests/base32.scm')
-rw-r--r--tests/base32.scm31
1 files changed, 1 insertions, 30 deletions
diff --git a/tests/base32.scm b/tests/base32.scm
index 134e578633..a999edcacc 100644
--- a/tests/base32.scm
+++ b/tests/base32.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015, 2020 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,26 +23,12 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-34)
#:use-module (srfi srfi-64)
- #:use-module (ice-9 rdelim)
- #:use-module (ice-9 popen)
#:use-module (ice-9 match)
#:use-module (rnrs bytevectors)
#:use-module (rnrs io ports))
;; Test the (guix base32) module.
-(define %nix-hash
- (or (and=> (getenv "NIX_HASH")
- (match-lambda
- ("" #f)
- (val val)))
- "nix-hash"))
-
-(define %have-nix-hash?
- ;; Note: Use `system', not `system*', because of <http://bugs.gnu.org/13166>.
- (false-if-exception
- (zero? (system (string-append %nix-hash " --version")))))
-
(test-begin "base32")
(test-assert "bytevector->base32-string"
@@ -85,19 +71,4 @@
(nix-base32-string->bytevector
(string-append (make-string 51 #\a) "e"))))
-;; The following test requires `nix-hash' in $PATH.
-(unless %have-nix-hash?
- (test-skip 1))
-
-(test-assert "sha256 & bytevector->nix-base32-string"
- (let ((file (search-path %load-path "tests/test.drv")))
- (equal? (bytevector->nix-base32-string
- (sha256 (call-with-input-file file get-bytevector-all)))
- (let* ((c (format #f "~a --type sha256 --base32 --flat \"~a\""
- %nix-hash file))
- (p (open-input-pipe c))
- (l (read-line p)))
- (close-pipe p)
- l))))
-
(test-end)