summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--guix/platforms/hurd.scm28
2 files changed, 0 insertions, 29 deletions
diff --git a/Makefile.am b/Makefile.am
index e993552fe9..bc114c9dae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -134,7 +134,6 @@ MODULES = \
guix/ipfs.scm \
guix/platform.scm \
guix/platforms/arm.scm \
- guix/platforms/hurd.scm \
guix/platforms/mips.scm \
guix/platforms/powerpc.scm \
guix/platforms/riscv.scm \
diff --git a/guix/platforms/hurd.scm b/guix/platforms/hurd.scm
deleted file mode 100644
index baa6c23b41..0000000000
--- a/guix/platforms/hurd.scm
+++ /dev/null
@@ -1,28 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix platforms hurd)
- #:use-module (guix platform)
- #:use-module (guix records)
- #:export (hurd))
-
-(define hurd
- (platform
- (target "i586-pc-gnu")
- (system "i586-gnu")
- (glibc-dynamic-linker "/lib/ld.so.1")))