aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Jarc <prj@po.cwru.edu>2009-01-04 21:27:41 -0500
committerJunio C Hamano <gitster@pobox.com>2009-01-05 19:46:19 -0800
commit50a4b35245bbdb0cfca5d62bc4295a2b2e4f1e87 (patch)
tree6fc60fa66fde6bdda1f829a3ccce26e368f7bd59 /configure.ac
parent0ddd93b2717d4da074485d42a08e4d3824580afe (diff)
downloadgit-50a4b35245bbdb0cfca5d62bc4295a2b2e4f1e87.tar.gz
git-50a4b35245bbdb0cfca5d62bc4295a2b2e4f1e87.tar.xz
configure clobbers LDFLAGS
In a couple of tests, configure clobbers the LDFLAGS value set by the caller. This patch fixes it. Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8821b5080..0a5fc8c6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,7 +127,7 @@ else
SAVE_LDFLAGS="${LDFLAGS}"
LDFLAGS="${SAVE_LDFLAGS} -Wl,-rpath,/"
AC_LINK_IFELSE(AC_LANG_PROGRAM([], []), [ld_wl_rpath=yes], [ld_wl_rpath=no])
- LDFLAGS="${SAVE_LD_FLAGS}"
+ LDFLAGS="${SAVE_LDFLAGS}"
])
if test "$ld_wl_rpath" = "yes"; then
AC_SUBST(CC_LD_DYNPATH, [-Wl,-rpath,])
@@ -136,7 +136,7 @@ else
SAVE_LDFLAGS="${LDFLAGS}"
LDFLAGS="${SAVE_LDFLAGS} -rpath /"
AC_LINK_IFELSE(AC_LANG_PROGRAM([], []), [ld_rpath=yes], [ld_rpath=no])
- LDFLAGS="${SAVE_LD_FLAGS}"
+ LDFLAGS="${SAVE_LDFLAGS}"
])
if test "$ld_rpath" = "yes"; then
AC_SUBST(CC_LD_DYNPATH, [-rpath])