aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJunio C Hamano <gitster@pobox.com>2016-10-28 09:01:12 -0700
committerJunio C Hamano <gitster@pobox.com>2016-10-28 09:01:12 -0700
commit68eb7b1b5222d5c9db2a9d5047bffe3fb65280f8 (patch)
tree88ac15180b8aaf573f860a1734d27d6a6c24dee1 /configure.ac
parent76796d424a21b1def8752c686708253a45721381 (diff)
parent842a516cb02a53cf0291ff67ed6f8517966345c0 (diff)
downloadgit-68eb7b1b5222d5c9db2a9d5047bffe3fb65280f8.tar.gz
git-68eb7b1b5222d5c9db2a9d5047bffe3fb65280f8.tar.xz
Merge branch 'js/regexec-buf' into maint
A follow-up to an already graduated topic. * js/regexec-buf: configure.ac: improve description of NO_REGEX test
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index aa9c91d20..7f39fd029 100644
--- a/configure.ac
+++ b/configure.ac
@@ -835,9 +835,10 @@ AC_CHECK_TYPE([struct addrinfo],[
])
GIT_CONF_SUBST([NO_IPV6])
#
-# Define NO_REGEX if you have no or inferior regex support in your C library.
-AC_CACHE_CHECK([whether the platform regex can handle null bytes],
- [ac_cv_c_excellent_regex], [
+# Define NO_REGEX if your C library lacks regex support with REG_STARTEND
+# feature.
+AC_CACHE_CHECK([whether the platform regex supports REG_STARTEND],
+ [ac_cv_c_regex_with_reg_startend], [
AC_EGREP_CPP(yippeeyeswehaveit,
AC_LANG_PROGRAM([AC_INCLUDES_DEFAULT
#include <regex.h>
@@ -846,10 +847,10 @@ AC_EGREP_CPP(yippeeyeswehaveit,
yippeeyeswehaveit
#endif
]),
- [ac_cv_c_excellent_regex=yes],
- [ac_cv_c_excellent_regex=no])
+ [ac_cv_c_regex_with_reg_startend=yes],
+ [ac_cv_c_regex_with_reg_startend=no])
])
-if test $ac_cv_c_excellent_regex = yes; then
+if test $ac_cv_c_regex_with_reg_startend = yes; then
NO_REGEX=
else
NO_REGEX=YesPlease